Wednesday, January 30, 2013

Fixing UNetbootin on Mac OS X to create a Bootable Linux USB

If you had issues trying to create a bootable linux usb for a pc, from your Mac, the below tutorial might help you. Even though it sounds slightly ironic, creating a pc bootable linux distro from a Mac, it's a situation I recently faced. So sharing the workaround.


The issue is the last version of UNetbootin I tried, extracts and installs linux successfully, however fails to create a bootable usb. So here are the steps



1. Go to finder/Spotlight, and launch Disk Utility
2. Select the usb disk, and create a partition. Format it as MS-DOS FAT and select Options > MBR
3. Go to the Terminal, and type the following


diskutil list

locate the name of your usb device. In my case it was rdisk2. Depending on your OS version it could differ.


diskutil unmountDisk /dev/rdisk2

Make the partition active and unmount the disk


sudo fdisk -e /dev/rdisk2
print
f 1
write
print
exit
diskutil unmountDisk /dev/rdisk2


4. Now, download the latest syslinux.zip, and extract and locate the mbr.bin
Go back to the extracted folder in the terminal, and install mbr.bin


sudo dd conv=notrunc bs=440 count=1 if=mbr.bin of=/dev/rdisk2


5. Now download and install UNetbootin for Mac, and proceed as usual. Select the distro and click ok.

This usb stick should be bootable on any pc, with your favorite distro :)


Credit: Paul Maunders SuperUser Forum

1 comment:

Dawsey said...

sudo dd conv=notrunc bs=440 count=1 if=mbr.bin of=/dev/disk2

replace rdisk for disk in Mountain Lion